Subject: Re: Gdk error with 1.7.6

From: Rich Burridge <[email-masked]>
Date: Fri, 01 Mar 2002 11:38:29 -0800 (PST)

Arrgh. I take it back. That won't stop at a breakpoint when it gets the
error. Try this:

Run in the debugger.

  % gdb faces
  gdb> break _XError
  gdb> run --g-fatal-warnings

That should hopefully stop at a break point when the error occurs, and 
you can then generate thje stack trace.

------------- Begin Forwarded Message -------------

Date: Fri, 1 Mar 2002 11:24:04 -0800 (PST)
From: Rich Burridge <[email-masked]>
Subject: Re: Gdk error with 1.7.6
To: [email-masked], [email-masked]
Mime-Version: 1.0
Content-MD5: Yg9VHJSxi4Ae5gjXYFOoeQ==

Hi Philippe,
 
> I use faces since 1991 with pleasure.
> Today I have tried to use faces-1.7.6.
> Compiling and linkink are OK, but when executing I got the following error:
> 
> Gdk-ERROR **: BadMatch (invalid parameter attributes)
>   serial 67 error_code 8 request_code 62 minor_code 0
> ...
> Does anybody know where the problem is ?

You can help me track it down. Try the following:

Run faces inside your debugger (I'm assuming you built it with gcc):

% gdb faces
gdb> run --g-fatal-warnings

Now when it gets the Gdk-ERROR it should stop and give you a gdb prompt.
Type:

gdb> where

This will give me a stack trace, which will help me determine where to look.

Thanks.

------------- End Forwarded Message -------------

---

From: Philippe Dax <[email-masked]>
Date: Mon, 4 Mar 2002 11:24:05 +0100

On 01/03, Rich Burridge wrote:
| 
| Run in the debugger.
| 
|   % gdb faces
|   gdb> break _XError
|   gdb> run --g-fatal-warnings

I have applied your modif in init_graphics:

    gtk_set_locale();
    gtk_init(argc, &argv);
    dpy = GDK_DISPLAY();
    XSynchronize(dpy, TRUE);	// <- added

But I got nothing:

GNU gdb 5.0
Copyright 2000 Free Software Foundation, Inc.
GDB is free software, covered by the GNU General Public License, and you are
welcome to change it and/or distribute copies of it under certain conditions.
Type "show copying" to see the conditions.
There is absolutely no warranty for GDB.  Type "show warranty" for details.
This GDB was configured as "sparc-sun-solaris2.7"...
(gdb) break _XError
Function "_XError" not defined.
(gdb) run --g-fatal-warnings
Starting program: /infres/horla/admin/dax/pub/tools/faces-1.7.6/faces/faces --g-fatal-warnings
Gdk-ERROR **: BadMatch (invalid parameter attributes)
  serial 105 error_code 8 request_code 62 minor_code 0

Program exited with code 01.
(gdb) where
No stack.
(gdb)