Subject: XFaces add ons...

From: "Mark Warren 415-506-4639" <[email-masked]>
Date: Thu, 27 Jan 1994 10:12:42 -0800

At someone's suggestion, I hacked together these two bits of emacs
lisp code to automatically add an X-Face: header to both my email and
new postings. I'm not sure how widespread gnus and/or emacs mail tools
are used, but it probably wouldn't hurt to put something like this in
your X-Faces distribution. What does the faces list think?

;; 
;; This will override the default behaviour of mail-signature whereby
;; the .signature file is added at the end of a mail message. Instead,
;; the signature will be added at point.
;;
(add-hook 'mail-setup-hook
      '(lambda ()
	 (defun mail-signature (&optional here)
	   "Sign letter with contents of ~/.signature at point and add an
X-Face header. If optional argument HERE is given, do not insert the
X-Face: header as well."
	   (interactive "P")
	   (save-excursion
	     (insert-file-contents (expand-file-name "~/.signature"))
	     (if (not here) (face-adder))
	     ))))

(defun face-adder ()
         (save-excursion
           (goto-char (point-min))
           (search-forward mail-header-separator)
           (beginning-of-line nil)
           (insert "X-Face:")
           (insert-file "~/.face")
	   (re-search-forward "RIPEM key on server")
	   (insert "
        The X-Face header is my picture! Get `faces' from cs.indiana.edu")
	   ))

(setq news-inews-hook
; Add my face image to the header of all news postings
      '(lambda ()
         (save-excursion
           (goto-char (point-min))
           (search-forward mail-header-separator)
           (beginning-of-line nil)
           (insert "X-Face:")
           (insert-file "~/.face"))))

---

From: Chris Liebman <[email-masked]>
Date: Thu, 27 Jan 1994 22:18:22 -0500 (EST)

Excerpts from mail: 27-Jan-94 XFaces add ons... Mark [email-masked] (1610)

> your X-Faces distribution. What does the faces list think?

   I have no problem adding things like this into the XFaces distribution.

   Over the past several days I have been considering adding a
"compface" (James Ashton's X-Face  header compression/decompression)
subdirectory or having this as a seperate distribution.  What is the
general thought on this?  Would you prefer this as a seperate
distribution? It really makes creating the distributions a lot easier.

			-- Chris (Hacking like crazey trying to add in some fancy parsing....)

Chris Liebman		Work			Home
Internet:	[email-masked]	[email-masked]
UUCP:		uunet!xrxedds!liebman	uunet!clarknet!zod!liebman
Phone:		1-703-787-2032		1-703-830-1641