Subject: XFaces 3.0 Announcement (finally!)

From: Chris Liebman <[email-masked]>
Date: Fri, 25 Feb 1994 20:00:15 -0500 (EST)

It was long.
It was painfull.
It is finaly out!

It can be had from:
	ftp.x.org:/contrib/xfaces-3.0.tar.Z
	ftp.clark.net:/pub/liebman/xfaces-3.0.tar.Z

Thanks to all the net.people who took time out of their busy schedules
to try the beta versions.  Most (if not all) of the problems identified
with the beta versions have been fixed.

		-- Chris

--------------- BLURB -----------------

			     XFaces 3.0
			Christopher B. Liebman
			[email-masked]
			   February 24, 1994

What is XFaces?

       XFaces is a program that will display an image for each
    piece of mail in your mail box.  This lets you know at a
    glance who you have mail from.  XFaces starts out (when you
    have no mail) looking like a color xbiff.  As you receive
    mail XFaces becomes a column of mail images.  Some of XFaces
    features:

      - Both mono and color images.

      - Optional Shaped window support with both xpm and xbm.

      - Sound support using the NetAudio protocol. The NetAudio server 
        currently supports Sun's SparcStation (SunOS 4.1.X and Solaris 2.2),
	SGI's Indigo and NCD MCX X terminals running NCDware 3.1 or later.

      - Face images can be "compressed" so that each image will only
        show up once on your display.  This way, if you receive 30 messages
        from one user, list or whatever the image will only show up once.

      - You can use regular expressions to search any headers to choose
        images and sounds or ignore that mail message compleatly. This
	lets you specify an image/sound for mail that comes from a
	mailing list or ignore mail that you have already seen but
	left in your system mailbox.

      - Compatibility support for Rich Burridge's faces program. This 
        includes the ability to run user command to generate the image
	list.

      - Support for POP mailboxes.

      - XFaces can kick off shell commands based upon mailbox
	contents.  You could have yourself paged when a high priorty
	item needs your attention.

      - XFaces can run external filters to convert images into Xpm
        so that image formats that XFaces does not understand can
	be used.

       XFaces is based on the Xt Intrinsics (-lXt) and the Athena
    Widget set (-lXaw).  To build in Xpm support you need the
    xpm library (-lxpm) version 3.2 or later.  To build in the
    sound support you will need NetAudio 1.1 or later. Both the xpm
    and the NetAudio distributions and publicly available with anon
    ftp from ftp.x.org in the contrib directory.

Whats new in this version?

Changes in version 3.0:		2/24/1994

       The major changes were to add compatibility support for
    Rich Burridge's "faces" program:

	- Per-face shell commands.
	
	- X-Face: header support.
	
	- facedb image/sound search. (the way faces finds
	  images)
	
	- User list commands.

	- Labling of images.  The user name and the number of messages
	  are displayed.

	- The following faces options are supported:
	      -f <facedbPath>
	      -e <listCommand>
	      -p <update time>
	      -c <# of columns>
	      -h <image height>
	      -w <image width>
	      -s <mail spool file>
	
	- POP mailbox support. (still primitive with respect to
	  user authentication but functional!)

	- A new Tiled widget so that the image list can be N 
	  columns and to allow for the "Rows=nnn Cols=nnn" line 
	  from a user command.

	- Full control of the order and imagetype/paths of searches.
	  The search types are:
	  
		- beforeImage,
		  afterImage,
		  beforeSound,
		  afterSound,
		  beforeCommand,
		  afterCommand:		These are regular expression searches
					on the mail headers.
		- resource:		Lookup image/sound in X resources.
		- facedb:		Lookup image/sound in "faces" style
					database.
		- x-face:		X-Face: style header.
	
	- Searchs are done for images, sounds and shell commands.
	
	- Much improved shape support.

Changes in version 2.3:		1/20/1994

       Compleatly rewrote the mail header parsing.  Now all headers
    are searched.

       Changed slightly the before/after image/sound bining format.
    Now you use three parts instead of to.  The new format is:
	    <header name> <whitespace> <pattern> <:> <image/sound file>

       Fixed a bug in the image code where a pixmap value was
    uninitialized and caused X error on some machines (machines where
    the unitialized value happened to be "None" worked!  others did
    not).

Changes in version 2.2:		1/14/1994

       Added new resource ignoreMessageBindings.  This allows you to
    have some messages ignored.

       Made the "Status:" header one of the headers that is searched
    with the bindings resources.  This allows people who like to keep
    200 to 300 messages in their system mailbox to only see/hear from
    messages that they have not seen yet.

       Made a small change to faces.h to allow for SystemV machines.
    I added macros for bcopy, bzero, index and rindex.

       Improved mail parsing. Before if there was no subject header
     xfaces could be fooled by a line in the body starting with Subject:.

Chris Liebman		Work			Home
Internet:	[email-masked]	[email-masked]
UUCP:		uunet!xrxedds!liebman	uunet!clarknet!zod!liebman
Phone:		1-703-787-2032		1-703-830-1641

---

From: [email-masked] (Paul Smith)
Date: Mon, 28 Feb 94 12:21:02 EST

%% Regarding XFaces 3.0 Announcement (finally!);
%% Chris Liebman <[email-masked]> writes:

    cl> It can be had from:
    cl> 	ftp.x.org:/contrib/xfaces-3.0.tar.Z
    cl> 	ftp.clark.net:/pub/liebman/xfaces-3.0.tar.Z

I'm having a strange problem: when I try to bring up the new xfaces I
get the following errors:

FaceImageTypeListParse: bad type name: <xpm-shape>
FaceImageTypeListParse: bad type name: <xpm>
FaceImageTypeListParse: bad type name: <xbm-shape>
FaceSearchParse: bad search type: <x-face>

and xfaces can't seem to find its pixmaps (I get a white square saying
"nomail" instead of the no-mailbox pixmap).

The only changes I made to the default app file were:

--- XFaces.ad   Fri Feb 25 19:27:01 1994
+++ /usr/global/lib/app-defaults/XFaces Mon Feb 28 12:11:11 1994
@@ -71,8 +71,8 @@
 ! lists.
 !
 
-XFaces.soundPath:      /usr/sounds:/usr/demo/SOUND/sounds
-XFaces.imagePath:      /usr/images
+XFaces.soundPath:      /usr/global/lib/sounds
+XFaces.imagePath:      /usr/global/lib/pixmaps
 
 !
 !  This is where we look for sounds/images in the "faces" format.
@@ -100,7 +100,7 @@
 ! image types are set in the imageTypes resource.
 !
 
-XFaces.facedbPath:     /usr/faces
+XFaces.facedbPath:     /usr/global/lib/faces/logos
 
 !
 !  Tell how many different annotations there are. We can support any number.

which shouldn't be a problem.  I start it with no args: "xfaces &".

Any ideas anyone? :(

                                                                paul
 _____________________________________________________________________________
/                                                                             \
 Paul D. Smith                   | "I'm not Gallagher, I'm the Dream Weaver."
 <[email-masked]>          | 
 Wellfleet Communications, Inc.  |                        -- _Robotman_
 Network Management Development  | 
\_____________________________________________________________________________/

---

From: [email-masked] (Paul Smith)
Date: Mon, 28 Feb 94 13:23:17 EST

cl> It can be had from:

Whoops, disregard my last email: brain-death over here!

I'm too used to FSF configure-generated makefiles: I was overriding
CFLAGS on the command line :(

However, it might be a little blurb for the README or whatever that if
you turn off XPM support you need to modify the XFaces.ad file to remove
that stuff from XFaces.imageFormats, and set the nomail image, etc.

                                                                paul
 _____________________________________________________________________________
/                                                                             \
 Paul D. Smith                   | There's a fine line between fishing, and
 <[email-masked]>          | standing on the shore like an idiot.
 Wellfleet Communications, Inc.  | 
 Network Management Development  |                            -- Steven Wright
\_____________________________________________________________________________/

---

From: Chris Liebman <[email-masked]>
Date: Mon, 28 Feb 1994 14:52:51 -0500 (EST)

Excerpts from mail: 28-Feb-94 Re: XFaces 3.0 Announcement.. Paul
[email-masked] (1955)

> FaceSearchParse: bad search type: <x-face>

You have built XFaces without XPM, SHAPE and XFace header support.  You
need to set the following resources:

XFaces.imageFormats:   xbm
XFaces.imageSearch:    \
		beforeImage\n\
		resource\n\
		facedb\n\
		afterImage

The defaults are:

XFaces.imageFormats:   xpm-shape:xpm:xbm-shape:xbm

Which specifies that the following image types are are allowd and the
order that they are to be checked:

	xpm-shape	- Shaped XPM images.
	xpm		- XPM images.
	xbm-shaped	- Shaped XBM images.
	xbm		- XBM images.

And:

XFaces.imageSearch:    \
		beforeImage\n\
		resource\n\
		facedb\n\
		x-face\n\
		afterImage

Which specifies the order and types of searches that are used to locate
an image to display.

	beforeImage	- regular expression search of headers.
	resource	- lookup user/host name in X resource database.
	facedb		- Disk based "faces" search.
	x-face		- look for X-Face header.
	afterImage	- regular expression search of headers.

> "nomail" instead of the no-mailbox pixmap).

Did you install a  nomail.xbm file in one of the directories on your
imagePath? (In your case: /usr/global/lib/pixmaps)  XFaces currently
does not contain a XBM nomail image.  Does anyone have one to contribute?

		-- Chris

Chris Liebman		Work			Home