Subject: xbm -> faces

From: [email-masked] (root@insight)
Date: Tue, 4 May 93 16:42:21 CDT

Well after serveral hours of capturing the images of our school, I am
ready to convert the .xbm to faces format. My inital try produces faces
that are skewed. I striped the .xbm and did the compfaces, did the elm
patch and get a X-Faces in the header, but the faces program shows it as
all screwed up. Any help?

---

From: "Steve Kinzler" <kinzler>
Date: Tue, 4 May 1993 16:51:59 -0500

Written Tue, 4 May 93 16:42:21 CDT by [email-masked] in mail:faces
+---------- "xbm -> faces" ----------
| Well after serveral hours of capturing the images of our school, I am
| ready to convert the .xbm to faces format. My inital try produces faces
| that are skewed. I striped the .xbm and did the compfaces, did the elm
| patch and get a X-Faces in the header, but the faces program shows it as
| all screwed up. Any help?

Are you converting the .xbm format into ikon format?  compfaces only
works with ikon format.

Here's what works for me:

	1) xbm2ikon < face.xbm > face.ikon	using the script below
	2) compface < face.ikon > face

If you'd like to submit the images for the facedir database, you can ftp
upload them to cs.indiana.edu:/pub/faces/incoming -- XBM format please.

--
from the brain of Steve Kinzler    /o)\    [email-masked]
an organ with a mind of its own    \(o/

-------------- CUT HERE ---------------
#!/bin/sh
#
#  @(#)xbm2ikon 1.4 91/05/06
#
#  Copyright (c) Steve Kinzler - March 1991.
#
#  Permission is given to distribute these sources, as long as the
#  copyright messages are not removed, and no monies are exchanged.
#
#  No responsibility is taken for any errors on inaccuracies inherent
#  either to the comments or the code of this program, but if reported
#  to me, then an attempt will be made to fix them.

PATH=$PATH:/usr/bin/X11; export PATH

# xbm2ikon - convert an X11 bitmap to a Blit ikon bitmap
# stdin/stdout filter
# requires some bitmap filters from the pbmplus package
# kludge by [email-masked]

xbmtopbm |
pbmtoicon |
sed -e 1,2d -e '$s/$/,/' |
tr -d '\011\012' |
tr ',' '\012' |
pr -l1 -t -w22 -3 -s, |
sed -e 's/$/,/' -e 's/\(0x....\)\(0x....\)\(0x....\),/\1,\2,\3,/'