Subject: Re: New faces application & faces monitoring in general

From: [email-masked] (Gunnar Forsgren)
Date: Thu, 18 Feb 93 16:06:48 +0100

> From: Boyd (Get in The Ring, ...) Roberts <[email-masked]>
> Date: Wed, 17 Feb 1993 22:01:52 +0100
> To: "Steve Kinzler" <[email-masked]>, [email-masked]
> Cc: [email-masked]
> Subject: Re: New faces application & faces monitoring in general
> In-Reply-To: <[email-masked]>
> X-Face: #"03$i1:"_[Hbg~GCPw}`+d4_R`}RaDfYixB`n-mCB0E8m#tNd>uyd[d<DIM0G$`0'*Yp+f
>  Qw-B0lP>)`nEix7Bys(:o#o2y7$(=,&BTXdH7)Hm5jP}H5:y]}0GT4?uTT(Y0(Cu7tWBXj\|q\@jZ8
>  Y_qn8)NV0*$uO][i7p"K2>Kg(
> Content-Length: 155
> Errors-To: [email-masked]
> X-Lines: 4
> 
> all i see here is a plethora of junk retrofitted into something that
> doesn't even work correctly at it's _base level_ functionality.
> 
> and that's progress?
> 
OK Boyd, so what is your contribution ?
Try /dev/null for a response that is on your level :-(
---
Gunnar Forsgren  Ericsson Telecom AB  email:<[email-masked]> 
S-126 25 Stockholm, SWEDEN     "No face is playing safe"

---

From: Boyd (Get in The Ring, ...) Roberts <[email-masked]>
Date: Fri, 19 Feb 1993 21:21:33 +0100

ok, i've got some 10 or so replies saying:

    `so, what would you know about it boyd?'

i'll tell you this:

   `faces' is based on the Eighth Edition UNIX `vismon'/`sysmon', a system
   i personally booted up, bug fixed, and enhanced in Sydney with John Mackin
   and Piers Lauder.

   another piece of the puzzle is that i've used the Plan 9 version
   (whose name i forget) at Bell Labs; it's small it works, and is
   a pleasure to use.  you can try and mail my Bell Labs Plan 9 account,
   but it will bounce.

   yes, i've read _Face The Nation_

   i have a Ninth Edition manual, as well as both Tenth Edition manuals.

   the PostScript Plan 9 manual sits on my desk.

what i am saying here is that that i can distinguish between good
and bad software.  i use faces every day, and everyday it's blatant
that it's core functionality is broken.

so, in closing, i'll quote Guns 'N Roses (Slash/Lank/Rose):

    don't damn me
    when i speak a piece of my mind
    'cause silence isn't golden
    when i'm holding it inside
    'cause i've been where i've been
    an i've seen what i've seen
    i put the pen to paper
    'cause it's all a part or me

        -- _Don't Damn Me_

           Guns 'N Roses
           Use Your Illusion I

---

From: "Matt Hughes" <[email-masked]>
Date: Fri, 19 Feb 93 15:27:44 CST

> that it's core functionality is broken.

I'm somewhat inclined to agree.  There is no arguing that a large amount
of time has been spent on this project -- perhaps what is needed is just
a better structure for change.  When the person who maintains the software
must spend a large amount of time doing real work, progress stops.

I really like the ideas that have been talked about -- configurable 
visual lists of whatever database there is seems to be essentially what we 
all want.  We just need to generalize it.  The faces project should not
be bogged down with hooks into everything, what it should be is a iconic
view of lists - any list.  These lists could be created with your basic
generic unix filter type approach.  This way someone can concentrate on
writing an application to read any list and find the correct icons, sounds,
etc, and other people can concentrate on little programs to build the
lists -- mail, printer queues, job queues, who's logged into what workstations
on the net, who's on this IRC "frequency," daily tasks of things to get
done, news groups that need reading, attorney general candidates, etc.

I can think of many reasons people don't use this software.  We need to
address them.

I've got this feeling like I'm soon to be flamed, but I'm not sure why.
Please respond with constructive critisism, I know I tried to.

I would like to donate my time on making it easier (and therefore portable
and more bug-free) for people to get their images into the various formats. 
I'd also like to clean up that area of the documentation.

Any other takers?

--
Matt Hughes    [email-masked]